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WARNING!
Toll fraud is committed when individuals unlawfully gain access to 
customer telecommunication systems. This is a criminal offense. 
Currently, we do not know of any telecommunications system that is 
immune to this type of criminal activity. AltiGen Communications, Inc., 
will not accept liability for any damages, including long distance charges, 
which result from unauthorized and/or unlawful use. Although AltiGen 
Communications, Inc.,  has designed security features into its products, it 
is your sole responsibility to use the security features and to establish 
security practices within your company, including training, security 
awareness, and call auditing.

NOTICE
While every effort has been made to ensure accuracy, AltiGen 
Communications, Inc., will not be liable for technical or editorial errors or 
omissions contained within the documentation. The information contained 
in this documentation is subject to change without notice.

This documentation may be used only in accordance with the terms of the 
AltiGen Communications, Inc., License Agreement.

AltiGen Communications, Inc.
410 East Plumeria Dr.
San Jose, CA 95134
Telephone:    888-AltiGen (258-4436)
Fax:               408-597-9020
E-mail:          info@altigen.com
Web site:       www.altigen.com

TRADEMARKS
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Enterprise Manager, AltiServ, AltiLink, AltiConsole, VRPlayer, 
Zoomerang, IPTalk, Alti-Mobile Extension, InTouch Dialer, AltiReport, 
and SuperQ are trademarks or registered trademarks of AltiGen 
Communications, Inc.

All other brand names mentioned are trademarks or registered trademarks 
of their respective manufacturers.
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Installing VRManager

VRManager performs recorded file management — indexing, converting, 
tracking, playback, reporting, and other critical functions for call center 
customers who would like to keep recorded files for administrative, legal, 
or quality assurance purposes. 

Requirements
Install VRManager on a different system than the one on which the 
MAXCS ACC/ACM server is installed. 

If you are upgrading, you can upgrade from VRManager 5.2 and above 
only. 

VRManager requires the following:

• VRManager License installed at the MAXCS ACC/ACM system. 
(You can verify the licenses when you run MaxAdministrator by 
selecting License > License Information.)

• MAX Communication Server (MAXCS) ACC/ACM (6.5 Update1or 
higher) 

• Pentium IV 2 GHz (minimum) CPU

• 40 GB available hard drive disk space

• 1 GB RAM

• IDE RAID 0-1 (minimum) hard drive

• NIC

• Microsoft Windows 2003 SP2

• Java 2 Runtime Environment (SE v1.4.2) (VRManager installation 
program will install this)

• MDAC (Microsoft Data Access Components) 2.8 or higher version

• Microsoft Internet Explorer 6.0 or later. A minimum installation is 
sufficient, and Internet Explorer does not have to be the default 
browser.
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Pre-Setup Required for MSDE 2000
The MSDE 2000 database is installed with the VRManager Setup 
program. MSDE 2000 requires certain settings in order to install 
successfully. Before running Setup, please ensure the following.

• File and print sharing must be active on your operating system. To 
verify: 

1. In Control Panel, double-click Network Connections. 

2. On the Advanced menu, click Advanced Settings. 

3. On the Adaptors and Bindings page, ensure that File and Print 
Sharing for Microsoft Networks is selected. 

• Make sure that Silently succeed is selected in the local security 
options named below. 

1. In Control Panel, double-click Administrative Tools. 

2. Double-click Local Security Policy. 

3. Expand Local Policies. 

4. Select Security Options. 

5. Ensure that the following option in the right pane is set to Silently 
succeed before installing: 

• On Windows 2003: Devices: Unsigned driver installation 
behavior. 

• Problems can occur if you use a Terminal Services or Remote Desktop 
connection to attempt to install a new instance of MSDE 2000. If 
problems are encountered, restart the VRManager Setup program 
from the local computer without using Terminal Services or Remote 
Desktop.

Installing VRManager Service
To install VRManager service, you will use one of two methods: Fresh 
install and Upgrade from previous version. 

Fresh Install
If you do a fresh install, the installation program installs MSDE 2000 and 
Jservice Loader on your PC automatically. 
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1. Run the Setup program and follow the installation instructions as they 
appear on the screen.

2. In the Custom Setup screen, choose to install Voice Record Manager 
Service and Voice Record Manager Admin. If you plan to use VRM 
Client at this system, also select Voice Record Manager Client. Then 
click Next.

After installation, you can run VRManager Admin from Start > Programs 
> VRManager > VRM Admin. 

Upgrade from Previous Version 
To upgrade from VRManager 5.2 or above:

1. Stop the VRM service.

2. Run the Setup program. 

3. Follow the installation instructions as they appear on the screen. 
In the Custom Setup screen, choose to install Voice Record Manager 
Service and Voice Record Manager Admin. If you plan to use 
VRManager Client at this system, also select Voice Record Manager 
Client.
VRManager Manual  3



Installing VRManager for a Client
Installing VRManager for a Client
To install VRManager for a client system: 

1. Run the Setup program and follow the installation instructions as they 
appear on the screen.

2. In the Custom Setup screen, choose to install Voice Record Manager 
Client or Voice Record Manager Admin.

If you install VR Admin on a client system, some Browse buttons 
will not appear.

After installation, you can run VRManager Client from Start > Programs 
> VRManager > VRM Admin or VRM Client.

Note:     If VRManager is run behind a firewall, open TCP port 10040. 
(VRManager may not work behind NAT.)

Setting Access Privileges
• The directory of centralized records in the MAXCS ACC/ACM server 

must be shared fully with the VRManager user. This user not only 
requires privilege to read/write to the shared folder, but also read/write 
to the local folder.

• The destination of the backup location must be valid and accessible in 
the local computer or remote computer. The user must have full 
privilege to read/write to the shared and local folders.

• In Windows 2003 Server, the default setting of the OS security is very 
robust, so caution should be used when setting users’ access privileges.
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C H A P T E R  2

Using VRManager Admin

To run VRManager Admin:

1. Choose Start > Programs > VRManager > VRM Admin. The VRM 
Admin Login dialog box opens.

2. Enter the VRM Server IP address or server name and Password. 
(Default password is 22222.)

3. Check the Save Password checkbox if you want VRM Admin to 
remember the password the next time the program is run. 

4. Click OK.

Note: Each Windows user has his own VRM Admin login setting.

VRM Admin Window
VRM Admin has five configuration pages:

• User

• Pooling

• Storage

• Log

• AltiWare ACC/ACM
VRManager Manual  5



User Page
The VRM User page displays the User List for VRManager clients and 
shows the workgroups, extensions, and systems that the user can query. 
From this page, an administrator can add, edit, and delete users; limit their 
queries to certain workgroups, extensions, and systems; change user 
passwords; and change the VRM Admin password.

Adding Users
To add a new VRManager Client user: 

1. Click the New button.
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In the New User dialog box, enter a User Name, Password and Password 
Confirmation. (The account name is NOT case-sensitive. For example, 
VRManager does not differentiate between the name “John” and “john” in 
a user account name.)

2. Click OK. 
The new user is displayed in the User List field.

3. To limit this user’s queries to certain workgroups, extensions, and 
systems, select the new user and click the Edit button. Enter the 
workgroup numbers in the Workgroup text box, the extension 
numbers in the Extension text box, and system IDs in the System ID 
text box. Separate entries with a comma. (To allow the user to query 
all workgroups or all extensions, leave those text boxes empty.)

Editing a User
To edit a user:

1. Select the user on the User page and click the Edit button.

2. Make your changes, and click OK.
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Changing the Admin Password
To change the VRM Admin password:

1. Click the Change Admin Password button. The Change Admin 
Password dialog box opens.

2. Enter the information in the Old Password, New Password and 
Confirm Password fields.

3. Click OK.
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Pooling Page
The pooling page lets you set the location of the primary storage directory. 
Use the Browse button to select the location. VRM Admin pools the newly 
recorded files from the MAXCS server, and saves them into the primary 
storage directory in the .wav format you select here (G.723.1, GSM, PCM).

Note: The Browse button is not available if VRM Admin is running on a 
different server than VRM Service.
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Storage Page
On the Storage page you can set backup conditions for the storage of voice 
records.

Select one of the following conditions:

• Automatic delete record without backup - if selected, VRM Admin 
will delete records without backing them up. To set additional 
automatic delete parameters, select any of the following options:

— Delete records older than x day(s)

— Delete records when free space below x MB

— Delete records when free space below x %

• Schedule Backup - if selected, VRM Admin will automatically back 
up, then delete records. To specify backup parameters, select any of 
the following options:

— Start when free space below x MB

— Start when free space below x %

Schedule - for detailed settings, click the Details button. In the 
Details dialog box, use the drop-down list to select the Schedule 
Task (Daily/Weekly/Monthly), use the up/down arrows to select 
the Start Time and to define the Daily Schedule (every x days), 
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Weekly Schedule (any day in every x weeks), or Monthly 
Schedule (any date in every month), then click Apply.

Use the Advanced button to set a Start Date and End Date; or 
check the Repeat Task checkbox to set up parameters for a 
continuous schedule, then click OK.

Check the Show multiple schedules checkbox to display and set up 
more than one schedule. You can add new multiple schedules, then 
modify them.

• Backup Storage - enter the location for the backup storage, or use the 
Update button to select a new location. If you click the Update button, 
the following dialog box opens:
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You can enter a local path or network path. The destination of the 
backup location must be valid and accessible in the local computer or 
remote computer. The user must have full privilege to read/write to 
the shared and local folders. Also, VRManager supports backup to 
DVD/RW; simply enter the path for the DVD/RW location.

Note: The Browse button is not available if VRM Admin is running 
on a different server than VRM Service.

• Execute Now button - clicking this button will begin backup of 
records.

When you have finished setting backup parameters, click Apply or OK.
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Log Page
A log file for the VRM server is created each day named “yyyymmdd.log” 
(for example, 20040404.log). A daily report for the VRM server is also 
created “yyymmdd.rpt” (for example, 20040404.rpt). The Log window 
allows an administrator to set the directory paths for VRM log and report.

Note: The Browse buttons are not available if VRM Admin is running on 
a different server than VRM Service.

• Set Log Directory - use the Browse button or enter a path in the field 
to specify where you want log files to be saved; check the Delete the 
log files older than x days checkbox to delete archived log files.

• Set Daily Report Directory - use the Browse button or enter a path in 
the field to specify where you want daily report files to be saved; check 
the Delete the log files older than x days checkbox to delete archived 
daily report files.

• Send daily report by mail - if you check this option, VRM will send 
a report When there is a warning or error or Always. Use the Mail 
Configuration button to configure the recipient’s email address. Use 
the Test button to send a test email.

Click Apply or OK when finished.
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AltiWare ACC or ACM Page
The AltiWare ACC or ACM page displays the MAXCS ACC or ACM 
servers and centralized recording directories that VRManager will access. 
Here, administrators can add or delete MAXCS ACC/ACM servers, and 
specify the centralized recording directory for the specified MAXCS 
ACC/ACM server.
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Adding Servers
To add a new MAXCS ACC/ACM server, do the following:

At the AltiServ system
1. Make sure the Centralized Storage directory is located on the local 

drive on the AltiServ system.

2. Share the storage directory with Full Control to a domain user or local 
administrator.

At the VRM Server
1. In the AltiWare ACC or ACM page of VRM Admin, click the New 

button.The Add New Server dialog box appears.

2. Enter the MAXCS ACC or ACM Server IP Address, Centralized 
Recording Directory (the Share name of the centralized recording 
folder) , User Name and Password. Then click OK. If the user 
account belongs to an NT domain, you must enter 
“NTDOMAIN;username” in the User Name edit box. If the account is 
local Administrator, just enter administrator. 

After adding a new server, VRM Service immediately checks the MAXCS 
server for the VRManager License.

The newly added server is displayed in the MAXCS ACC or ACM Server 
List field.

Note: VRManager starts converting all voice recording data as soon as 
the MAXCS ACC/ACM Server information is added to the 
MAXCS ACC or ACM Server List.
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Changing the Centralized Recording Directory
To edit a MAXCS ACC/ACM server’s location for the centralized 
recording directory, highlight the MAXCS ACC/ACM server in the server 
list, then input the new location in the Centralized Recording Directory 
field.
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C H A P T E R  3

Using VRManager Client

To run VRManager Client:

1. Choose Start > Programs > VRManager > VRM Client. A Login 
dialog box opens

.

2. Enter the VRM Server IP address or server name, User name and 
Password. 

3. Check the Save Password checkbox to have VRM Client remember 
the password the next time the program is run. 

4. Click OK.

Note: Each Windows user has his own VRM Client login setting.
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VRM Client Main Window
VRM Client Main Window
When you start VRM Client, the first window you see is the VRM Client 
main window.

At the top is a menu bar, and below is a quick-access toolbar. At the bottom 
is a scroll bar for viewing the display columns.

Note: Each Windows user has his own VRM Client display column in the 
main window.

Menu Bar
Using the menus, you can perform the following functions:

• File – Save As, Export to File, Change Password, Exit

• Edit – Search, Play, Display Column, Option

• Report – Generate report

• Help – VRM Client version information
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VRM Client Main Window
Quick Access Toolbar
The toolbar contains buttons that are menu shortcuts:

File Menu
Saving Files
To save a file, click on a voice record in the main window to highlight it, 
and click the Save As button. OR, right-click on a voice record, and select 
Save As. OR, click on a voice record to highlight it, and choose File > Save 
As from the main menu.

Saves the selected voice recording 
to a specified location

Plays the 
selected voice 
recording

Opens Report 
Generation dialog box

Opens client 
version 
information

Opens search 
options
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VRM Client Main Window
Export to File
To export search results to a tab-separated text file (.txt), choose File > 
Export To File from the main menu, OR right-click the search results list 
and choose Export To File.

Change Password
To change your password: 

1. Choose File > Change Password from the main menu. 

2. In the Change User Password dialog box, enter the necessary 
information in the Old Password, New Password and Confirm 
Password fields, then click OK.

The new password applies at the next log in. 
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VRM Client Main Window
Edit Menu
Searching Voice Records
To search voice records, choose Edit > Search or click the Search button 
in the toolbar. In the Search dialog box, you can search based on the 
following conditions:

The relational symbols for each condition include:
= (equal)
< (greater than)
> (less than)
>= (less than or equal to)
<= (greater than or equal to)
<> (not equal)
like (look for sub-string)
btwn (between)
in—searches the results in sets; for example, CallerID “In” “101 AND 
102” means CallerID equals 101 or CallerID equals 102.

Notes
• The date/time format is the same as the system format of the operating 

system.

• Typing “OR” in upper case in the edit box means “or.”

• Typing “AND” in upper case in the edit box means “and.”

• To leave out a condition, leave the edit box empty. 
VRManager Manual  21



VRM Client Main Window
• Only the Comment column will be editable directly from the main 
view window.

Searching for All an Extension’s Voice Records
If you query a specified extension’s voice records and in that query you also 
specify a workgroup, the query results show only the extension’s voice 
records related to the workgroup. The results do not show non-workgroup 
voice records. 

If you want the query results to display all voice records for that extension, 
leave the WorkGroup field blank.

Playing Voice Records
To play a voice record:

Click on a voice record in the main window to highlight it, and click the 
Play button. OR, right click on a voice record and select Play. OR, click on 
a voice record to highlight it, and choose Edit > Play from the main menu.

Note: Deleted voice files are not played.

Displaying Columns
You can select which columns you want displayed in the main view 
window. These are the column headers you can select from:

• ID
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VRM Client Main Window
• Callee ID

• Session ID

• Caller ID

• DNIS

• Workgroup

• Length

• Date

• State—there are three states that a record file can be in:

— Delete - if in this state, a record cannot be played or saved.

— Backup - if in this state, you must manually put the right backup 
media in the path if you back up the record and remove it.

— Normal - if in this state, the file can be played or saved.

• Comment

To select columns for display: 

1. Choose Edit > Select Column. 
The Select Column dialog box opens. The fields in the Visible list are 
displayed as columns under the VRM toolbar.

.

2. Use the arrow keys (< or >) to move a field from one list to the other. 
You can use the << or >> buttons to move the entire group of fields 
from one list to the other. 

3. Click OK when finished.
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VRM Client Main Window
Sorting
In the main view window, you can click on a specific column heading to 
sort records in ascending or descending order on that field. You can use the 
scroll bar at the bottom of the window to view all the displayed columns.

Media Player Option
VRM client plays the selected file using a media player defined by the user. 
If the media player is not defined, VRManager does not play the file, and 
instead opens the Media Player Location dialog box so you can assign a 
media player. You can also select the media player by going to Edit > 
Option. In the Option dialog box, select the Media Player Location by 
typing the path in the field or using the browse button (...), then click OK.

Report Menu
You can generate reports based on agent, workgroup, DNIS or date. 

To generate a report:

1. Choose Report from the main menu or click the Report button. The 
Report Generation dialog box opens.
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VRM Client Main Window
2. In the Report Generation dialog box, click the Down arrow to select 
From and To dates from a calendar.

3. Select one of the following format options:

• Group by Agent Extension—select Callee ID or Caller ID, or 
both, and enter the agent’s extension in the field.

• Group by Workgroup—enter the workgroup number in the 
Workgroup field.

• Group by DNIS—enter the DNIS number in the DNIS field.

• Group by Day (Daily Summary)—formats report based on date 
period summary for each day.

4. Click OK.

5. VRM Client generates a separate Report window displaying the 
selected report parameters. From there, you can select Print Setup, 
Preview, Print, or Export (as a tab-separated text file).
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VRM Client Main Window
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